WD ending support for My cloud OS 3 and earlier

Akash jain Estimated Read Time: 1 Minutes

Many customers have received an email from WD that support for older my cloud devices is being discontinued. There will be no further updates for devices running on OS 3 and earlier, leaving them vulnerable to security issues, and there are many.

If you have a device currently running OS3 or earlier, what are your options?

Update to OS5  if you can.

If your device is compatible with OS5, you can upgrade, and you should do so immediately. Current models like EX2 ultra, EX4100, PR2100 and PR4100 are upgradeable and some older models like DL2100, DL4100 and My cloud mirror gen2 are also upgradeable. WD has published a list of all models that are upgradeable.

If you have a model that can be upgraded to OS5, you do not have to worry. Just upgrade and use them as usual, at least until 2026, because WD says they will support this version until 2026.

Use device only locally if you can not upgrade

What if you have an old device that can not be upgraded and has to run OS3 or earlier. In this case, an internet connection would only lead to the device being targeted. So WD recommends that you only use the device locally and not have access to the internet. The email states

"We recommend that you immediately secure your device, [disable remote access], disconnect it from the Internet, and then protect it with a strong, unique password."

And yes, the email says that you will receive a 20% off coupon that you can use towards the purchase of any of the following devices: My Cloud Home 8TB, My Book 12TB, My Cloud EX2 Ultra 16TB, 24TB, 28TB and My Book 12TB. You do not have to return your old device. It's not clear yet how the coupons will work in the Middle East, but we will know soon.

Add a comment

* Comments must be approved before being displayed.